# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?x)\n"
r"(\/\/[ \t]*)\n"
r"(\n"
r"\[(?:\n"
r" (?:[-]?\d+(?:.\d)*)(?:[ \t]*:[ \t]*-?\d+(?:.\d)*){0,2} \n"
r" |\n"
r" (?:(?:[^:,]+:)?[^:,]+,)*(?:(?:[^:,]+:)?[^:,]+)\n"
r")\]\n"
r")\n"
r"[ \t]*$\n?")
test_str = ("\n"
"// Internal Diameter\n"
"innerWidth = 11.733333; // [40]\n"
"innerWidth = 11.733333; \n"
"// \n"
"[Invalid: thing]\n"
"height = 14;\n"
"wallWidth = 2;\n\n"
"//#region [Options] Advanced\n\n"
"/* [Advanced Options] */\n"
"enable_sloped_walls =true; // [10:20]\n"
"outerWidth_delta = 0.2;\n\n"
"enable_sloped_walls_inner = true;\n"
"innerDelta = -1;\n\n"
"rounded_top = true;\n"
"rounding_top = nothing * 5;\n\n"
"rounded_bottom = false;\n"
"rounding_bottom = 1.5;")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.