using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*{2}([a-zA-Z0-9]+)\*{2}";
string input = @"**Only single**, alphanumeric p**art**s of **words** enclosed by two asterisks should be matched.****";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}