re = /\*{2}([a-zA-Z0-9]+)\*{2}/
str = '**Only single**, alphanumeric p**art**s of **words** enclosed by two asterisks should be matched.****'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end