package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\*{2}([a-zA-Z0-9]+)\*{2}`)
var str = `**Only single**, alphanumeric p**art**s of **words** enclosed by two asterisks should be matched.****`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}