$re = '/\*{2}([a-zA-Z0-9]+)\*{2}/';
$str = '**Only single**, alphanumeric p**art**s of **words** enclosed by two asterisks should be matched.****';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);