// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\*{2}([a-zA-Z0-9]+)\*{2}").unwrap();
let string = "**Only single**, alphanumeric p**art**s of **words** enclosed by two asterisks should be matched.****";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}