import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!doc$).)*$";
final String string = "group/ps/doc\n"
+ "group/doc\n"
+ "doc\n"
+ "groups/release\n"
+ "dev/releas\n"
+ "docker/release\n"
+ "group/cloud-doc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}