$re = '/^((?!doc$).)*$/m';
$str = 'group/ps/doc
group/doc
doc
groups/release
dev/releas
docker/release
group/cloud-doc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);