re = /^((?!doc$).)*$/m
str = 'group/ps/doc
group/doc
doc
groups/release
dev/releas
docker/release
group/cloud-doc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end