import re
regex = re.compile(r"^((?!doc$).)*$", flags=re.MULTILINE)
test_str = ("group/ps/doc\n"
"group/doc\n"
"doc\n"
"groups/release\n"
"dev/releas\n"
"docker/release\n"
"group/cloud-doc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")