using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?:\/\/)?www\.website\.com\/sample\.pdf$";
string input = @"www.website.com/sample.pdf
http://www.website.com/sample.pdf
https://www.website.com/sample.pdf
https://www.website.com/sample.pd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}