// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(https?:\/\/)?www\.website\.com\/sample\.pdf$").unwrap();
let string = "www.website.com/sample.pdf
http://www.website.com/sample.pdf
https://www.website.com/sample.pdf
https://www.website.com/sample.pd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}