package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?:\/\/)?www\.website\.com\/sample\.pdf$`)
var str = `www.website.com/sample.pdf
http://www.website.com/sample.pdf
https://www.website.com/sample.pdf
https://www.website.com/sample.pd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}