re = /^(https?:\/\/)?www\.website\.com\/sample\.pdf$/m
str = 'www.website.com/sample.pdf
http://www.website.com/sample.pdf
https://www.website.com/sample.pdf
https://www.website.com/sample.pd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end