$re = '/^(https?:\/\/)?www\.website\.com\/sample\.pdf$/m';
$str = 'www.website.com/sample.pdf
http://www.website.com/sample.pdf
https://www.website.com/sample.pdf
https://www.website.com/sample.pd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);