#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.{1,2}?\*)(?!(?:.*?\*){2})[\w .?*,]{3,40}$"
Local $sString = "I am some testdata" & @CRLF & _
"I am * some testdata" & @CRLF & _
"I*am some testdata" & @CRLF & _
"I am * some * testdata" & @CRLF & _
"I am some testdata and I am much longer than the maximum" & @CRLF & _
"AB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")