import re
regex = re.compile(r"^(?!.{1,2}?\*)(?!(?:.*?\*){2})[\w .?*,]{3,40}$", flags=re.MULTILINE)
test_str = ("I am some testdata\n"
"I am * some testdata\n"
"I*am some testdata\n"
"I am * some * testdata\n"
"I am some testdata and I am much longer than the maximum\n"
"AB")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")