$re = '/^(?!.{1,2}?\*)(?!(?:.*?\*){2})[\w .?*,]{3,40}$/m';
$str = 'I am some testdata
I am * some testdata
I*am some testdata
I am * some * testdata
I am some testdata and I am much longer than the maximum
AB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);