import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.{1,2}?\\*)(?!(?:.*?\\*){2})[\\w .?*,]{3,40}$";
final String string = "I am some testdata\n"
+ "I am * some testdata\n"
+ "I*am some testdata\n"
+ "I am * some * testdata\n"
+ "I am some testdata and I am much longer than the maximum\n"
+ "AB";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}