re = /^(?!.{1,2}?\*)(?!(?:.*?\*){2})[\w .?*,]{3,40}$/m
str = 'I am some testdata
I am * some testdata
I*am some testdata
I am * some * testdata
I am some testdata and I am much longer than the maximum
AB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end