const regex = /(cust)?(\*?ac.*(ct|cnt|unt)\.?)(\#|no\.?|number)\*?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(cust)?(\\*?ac.*(ct|cnt|unt)\\.?)(\\#|no\\.?|number)\\*?', 'gmi')
const str = `accountno.
AccountNumber
accountnumber
AccountNumber
CustAccountNo.*
ACCT.NO.
ACCT.NUMBER
ACCOUNT#
ACCT.NO.
AcctNo
*AccountNumber
*AccountNumber
AccountNumber*
AccountNumber
AccntNo
(cust)?\\s?(^\\s+)?(\\*?(ac(.*)unt)|(acct\\.?))\\s?(\\#|no\\.?|number)(\\*)?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}