$re = '/(cust)?(\*?ac.*(ct|cnt|unt)\.?)(\#|no\.?|number)\*?/mi';
$str = 'accountno.
AccountNumber
accountnumber
AccountNumber
CustAccountNo.*
ACCT.NO.
ACCT.NUMBER
ACCOUNT#
ACCT.NO.
AcctNo
*AccountNumber
*AccountNumber
AccountNumber*
AccountNumber
AccntNo
(cust)?\\s?(^\\s+)?(\\*?(ac(.*)unt)|(acct\\.?))\\s?(\\#|no\\.?|number)(\\*)?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);