import re
regex = re.compile(r"(cust)?(\*?ac.*(ct|cnt|unt)\.?)(\#|no\.?|number)\*?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("accountno.\n"
"AccountNumber\n"
"accountnumber\n"
"AccountNumber\n"
"CustAccountNo.*\n"
"ACCT.NO.\n"
"ACCT.NUMBER\n"
"ACCOUNT#\n"
"ACCT.NO.\n"
"AcctNo\n"
"*AccountNumber \n"
"*AccountNumber\n"
"AccountNumber*\n"
"AccountNumber \n"
"AccntNo\n\n\n"
"(cust)?\\s?(^\\s+)?(\\*?(ac(.*)unt)|(acct\\.?))\\s?(\\#|no\\.?|number)(\\*)?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")