// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(cust)?(\*?ac.*(ct|cnt|unt)\.?)(\#|no\.?|number)\*?").unwrap();
let string = "accountno.
AccountNumber
accountnumber
AccountNumber
CustAccountNo.*
ACCT.NO.
ACCT.NUMBER
ACCOUNT#
ACCT.NO.
AcctNo
*AccountNumber
*AccountNumber
AccountNumber*
AccountNumber
AccntNo
(cust)?\\s?(^\\s+)?(\\*?(ac(.*)unt)|(acct\\.?))\\s?(\\#|no\\.?|number)(\\*)?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}