re = /(cust)?(\*?ac.*(ct|cnt|unt)\.?)(\#|no\.?|number)\*?/mi
str = 'accountno.
AccountNumber
accountnumber
AccountNumber
CustAccountNo.*
ACCT.NO.
ACCT.NUMBER
ACCOUNT#
ACCT.NO.
AcctNo
*AccountNumber
*AccountNumber
AccountNumber*
AccountNumber
AccntNo
(cust)?\\s?(^\\s+)?(\\*?(ac(.*)unt)|(acct\\.?))\\s?(\\#|no\\.?|number)(\\*)?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end