const regex = /(^(?:\s?[\w\d]+){8})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(?:\\s?[\\w\\d]+){8})', 'gm')
const str = `43RF 43RF 43RF 43RF 43RF 43RF 43RF 43RF 234hiyue..wgreoriauw..erh..
43RF 43RF 43RF 43RF 43RF 43RF 43RF 43RF 234hiyue..wgreoriauw..erh..`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);