use strict;
my $str = '43RF 43RF 43RF 43RF 43RF 43RF 43RF 43RF 234hiyue..wgreoriauw..erh..
43RF 43RF 43RF 43RF 43RF 43RF 43RF 43RF 234hiyue..wgreoriauw..erh..';
my $regex = qr/(^(?:\s?[\w\d]+){8})/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";