import Foundation
let pattern = #"(^(?:\s?[\w\d]+){8})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
43RF 43RF 43RF 43RF 43RF 43RF 43RF 43RF 234hiyue..wgreoriauw..erh..
43RF 43RF 43RF 43RF 43RF 43RF 43RF 43RF 234hiyue..wgreoriauw..erh..
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)