#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*(?i)href\s*=\s*(\"([^"]*\")|'[^']*'|([^'">\s]+))"
Local $sString = "I'm at Harrah's Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others <a href="http://t.co/UjxTIdiJ">http://t.co/UjxTIdiJ</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")