package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(?i)href\s*=\s*(\"([^"]*\")|'[^']*'|([^'">\s]+))`)
var str = `I'm at Harrah's Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others <a href="http://t.co/UjxTIdiJ">http://t.co/UjxTIdiJ</a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}