re = /\s*(?i)href\s*=\s*(\"([^"]*\")|'[^']*'|([^'">\s]+))/
str = 'I\'m at Harrah\'s Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others <a href="http://t.co/UjxTIdiJ">http://t.co/UjxTIdiJ</a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end