using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?i)href\s*=\s*(\""([^""]*\"")|'[^']*'|([^'"">\s]+))";
string input = @"I'm at Harrah's Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others <a href=""http://t.co/UjxTIdiJ"">http://t.co/UjxTIdiJ</a>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}