import Foundation
let pattern = #"\s*(?i)href\s*=\s*(\"([^"]*\")|'[^']*'|([^'">\s]+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I'm at Harrah's Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others <a href="http://t.co/UjxTIdiJ">http://t.co/UjxTIdiJ</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}