using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{Template1(?:[^{}]*?(?:{{[^}]+?}}))+(?:}+)*";
string input = @"...
abas asdn asf asfs af{{Template1|a = Name surname|b = jhsdf sdf|c = {{Template2}}|d = |e = [[f]] and [[g]]|h = asd asdasfgasgasg asgas jygh trdx dftf xcth|i = 73|j = {{Template2|abc|123}}|j = {{Template3|aa=kkk|bb={{Template4|cc=uu}}}}}}asd wetd gdsgwew g{{OtherTemplate|sdf 213}}...";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}