re = /{{Template1(?:[^{}]*?(?:{{[^}]+?}}))+(?:}+)*/m
str = '...
abas asdn asf asfs af{{Template1|a = Name surname|b = jhsdf sdf|c = {{Template2}}|d = |e = [[f]] and [[g]]|h = asd asdasfgasgasg asgas jygh trdx dftf xcth|i = 73|j = {{Template2|abc|123}}|j = {{Template3|aa=kkk|bb={{Template4|cc=uu}}}}}}asd wetd gdsgwew g{{OtherTemplate|sdf 213}}...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end