using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\s(?<Memory>.\d*)\s(?<Cpu>.\d*)\s(?<Truc>[^\s+]*)";
string substitution = @"";
string input = @"20160607-10:27:01 427369444501 14445 2.9788888 37.1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}