package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\s(?<Memory>.\d*)\s(?<Cpu>.\d*)\s(?<Truc>[^\s+]*)`)
var str = []byte(`20160607-10:27:01 427369444501 14445 2.9788888 37.1`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}