import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\s(?<Memory>.\\d*)\\s(?<Cpu>.\\d*)\\s(?<Truc>[^\\s+]*)";
final String string = "20160607-10:27:01 427369444501 14445 2.9788888 37.1";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}