package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<year>\d{2})(?P<month>\d{2})(?P<day>\d{2}) (?P<hour>\d{2}):(?P<min>\d{2}).+: (?P<tr_amount>-[\d\.]+) (?P<tr_currency>\w+);(?P<merchant>.+);.+(?P<card>\d{4});.+(?P<acc_balance>[\+-][\d\.]+) (?P<acc_currency>\w+).+`)
var str = `160514 21:31 Kàrtyàs vàsàrlàs/zàrolàs: -7.185 HUF; PAYPAL *FACEBOOK, IE 35314369001 PAYPAL *FACEBOOK; Kàrtyaszàm: ...6297; Egyenleg: +136.798 HUF - SIMPLE`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}