$re = '/(?P<year>\d{2})(?P<month>\d{2})(?P<day>\d{2}) (?P<hour>\d{2}):(?P<min>\d{2}).+: (?P<tr_amount>-[\d\.]+) (?P<tr_currency>\w+);(?P<merchant>.+);.+(?P<card>\d{4});.+(?P<acc_balance>[\+-][\d\.]+) (?P<acc_currency>\w+).+/';
$str = '160514 21:31 Kàrtyàs vàsàrlàs/zàrolàs: -7.185 HUF; PAYPAL *FACEBOOK, IE 35314369001 PAYPAL *FACEBOOK; Kàrtyaszàm: ...6297; Egyenleg: +136.798 HUF - SIMPLE';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);