// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<year>\d{2})(?P<month>\d{2})(?P<day>\d{2}) (?P<hour>\d{2}):(?P<min>\d{2}).+: (?P<tr_amount>-[\d\.]+) (?P<tr_currency>\w+);(?P<merchant>.+);.+(?P<card>\d{4});.+(?P<acc_balance>[\+-][\d\.]+) (?P<acc_currency>\w+).+").unwrap();
let string = "160514 21:31 Kàrtyàs vàsàrlàs/zàrolàs: -7.185 HUF; PAYPAL *FACEBOOK, IE 35314369001 PAYPAL *FACEBOOK; Kàrtyaszàm: ...6297; Egyenleg: +136.798 HUF - SIMPLE";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}