import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<year>\\d{2})(?P<month>\\d{2})(?P<day>\\d{2}) (?P<hour>\\d{2}):(?P<min>\\d{2}).+: (?P<tr_amount>-[\\d\\.]+) (?P<tr_currency>\\w+);(?P<merchant>.+);.+(?P<card>\\d{4});.+(?P<acc_balance>[\\+-][\\d\\.]+) (?P<acc_currency>\\w+).+";
final String string = "160514 21:31 Kàrtyàs vàsàrlàs/zàrolàs: -7.185 HUF; PAYPAL *FACEBOOK, IE 35314369001 PAYPAL *FACEBOOK; Kàrtyaszàm: ...6297; Egyenleg: +136.798 HUF - SIMPLE";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}