const regex = new RegExp('(?P<year>\\d{2})(?P<month>\\d{2})(?P<day>\\d{2}) (?P<hour>\\d{2}):(?P<min>\\d{2}).+: (?P<tr_amount>-[\\d\\.]+) (?P<tr_currency>\\w+);(?P<merchant>.+);.+(?P<card>\\d{4});.+(?P<acc_balance>[\\+-][\\d\\.]+) (?P<acc_currency>\\w+).+', '')
const str = `160514 21:31 Kàrtyàs vàsàrlàs/zàrolàs: -7.185 HUF; PAYPAL *FACEBOOK, IE 35314369001 PAYPAL *FACEBOOK; Kàrtyaszàm: ...6297; Egyenleg: +136.798 HUF - SIMPLE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}