#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:/\*|\G(?!^))(?:(?!\*/)[^$])*\K\$var\s*=\s*(?:(?!\*/)[^$;])*"
Local $sString = "/* other code $var = value1 */" & @CRLF & _
"$var = value2 ;" & @CRLF & _
"" & @CRLF & _
"/* " & @CRLF & _
"other code" & @CRLF & _
"$var = value3 ;" & @CRLF & _
"other code" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"$var = value4;" & @CRLF & _
"$var = value5;" & @CRLF & _
"" & @CRLF & _
"/* " & @CRLF & _
"other code" & @CRLF & _
"$var = value6;" & @CRLF & _
"$var = value7;" & @CRLF & _
"$var = value8" & @CRLF & _
"*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")