import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:/\\*|\\G(?!^))(?:(?!\\*/)[^$])*\\K\\$var\\s*=\\s*(?:(?!\\*/)[^$;])*";
final String string = "/* other code $var = value1 */\n"
+ "$var = value2 ;\n\n"
+ "/* \n"
+ "other code\n"
+ "$var = value3 ;\n"
+ "other code\n"
+ "*/\n\n\n"
+ "$var = value4;\n"
+ "$var = value5;\n\n"
+ "/* \n"
+ "other code\n"
+ "$var = value6;\n"
+ "$var = value7;\n"
+ "$var = value8\n"
+ "*/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}