import Foundation
let pattern = #"(?:/\*|\G(?!^))(?:(?!\*/)[^$])*\K\$var\s*=\s*(?:(?!\*/)[^$;])*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/* other code $var = value1 */
$var = value2 ;
/*
other code
$var = value3 ;
other code
*/
$var = value4;
$var = value5;
/*
other code
$var = value6;
$var = value7;
$var = value8
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)