const regex = new RegExp('(?:/\\*|\\G(?!^))(?:(?!\\*/)[^$])*\\K\\$var\\s*=\\s*(?:(?!\\*/)[^$;])*', 'g')
const str = `/* other code \$var = value1 */
\$var = value2 ;
/*
other code
\$var = value3 ;
other code
*/
\$var = value4;
\$var = value5;
/*
other code
\$var = value6;
\$var = value7;
\$var = value8
*/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}