re = /(?:\/\*|\G(?!^))(?:(?!\*\/)[^$])*\K\$var\s*=\s*(?:(?!\*\/)[^$;])*/
str = '/* other code $var = value1 */
$var = value2 ;
/*
other code
$var = value3 ;
other code
*/
$var = value4;
$var = value5;
/*
other code
$var = value6;
$var = value7;
$var = value8
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end