const regex = /^isCellValueEqualTo\(('[0-9]+\.[0-9]+'), ('CashValue')\);$/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^isCellValueEqualTo\\((\'[0-9]+\\.[0-9]+\'), (\'CashValue\')\\);$', 's')
const str = `isCellValueEqualTo('100.00', 'CashValue');`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);