$re = '/^isCellValueEqualTo\((\'[0-9]+\.[0-9]+\'), (\'CashValue\')\);$/s';
$str = 'isCellValueEqualTo(\'100.00\', \'CashValue\');';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;